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Dolphin Power Tools Overview

Accessing and Upgrading Power Tools

Note: Screen captures/icons in this user’s guide may differ from what appears on your device.

Dolphin Power Tools are installed in every Dolphin terminal. Different versions of Power Tools apply to
different Dolphin terminals depending on their model or operating system.

Power Tool Windows Mobile 5/6/ Windows Mobile 2003 Windows CE 5.0
6.1/6.5 Second Edition
6.0: 7600 (GSM) 7900/9500 7600
6.1: 9900
6.5: 9700
5.0: 7850/7900/9500
Autolnstall . . .
Autorun . . .
Battery Analyzer .
(only on the 9700/9900)
BattMon . . .

DeviceConfig

EZConfig Editor

EZConfig Client

EZMenu

HotKeys

Keyboard Status

Network Utilities:

IPConfig

Ping

Route

WiFi Status

Backup Radio Settings

Restore Radio Settings

NoSIP

RASMan

Reboot

RegBackup

RegEdit

RegRestore

ScanWedge




Power Tool Windows Mobile 5/6/ Windows Mobile 2003 Windows CE 5.0
6.1/6.5 Second Edition

SetRAM o

Suspend . . o

Sysinfo o . o

Software Requirements

Dolphin Terminals
Dolphin Power Tools are designed to work with Windows Mobile® 6
Desktop

The Power Tools installer and the workstation version of EZConfig Editor are designed to work with the
following operating systems:

¢ Microsoft® Windows® XP

* Microsoft® Windows® 2000

* Microsoft® Windows® NT

¢ Microsoft® Windows® Vista

e Microsoft® .NET Framework 2.0

* Microsoft® ActiveSync® (version 4.5 or higher)

Power Tools Main Window

Tap Start > Power Tools and the Power Tools main window opens displaying the main Power Tools.

BattMon EZConfig
LUtilities

£ B

Keyboard Metwiork MoSIP
Status Utilities

B # F

Reboot RegBackup  RegRestore

&
¥
E

File ¥iew Help
Icon Name Description Page
A BattMon Programs the LEDs on the top panel to monitor battery power. | 6-2
EattMon
EZConfig Opens a window that displays the EZConfig utilities on the 2-1
Utilities terminal. =~ .
e EZConfig Editor on the Terminal (see page 2-30)
e EZConfig Client (see page 2-34)




=]
SysInfio

Icon Name Description Page
g_ HotKeys Activates button assignments in the Buttons setting. 6-5
Hotkeys
Keyboard Puts an icon on the Navigation bar that indicates the alpha- 6-7
orboard Status numeric status of the keyboard.
Status
@ NoSIP Turns off the Soft Input Panel (SIP) in every application window. | 6-9
MNoSIP
g Network Opens a window that displays the Network utilities: 9-1
Network Utilities * IP Config (see page 9-2)
Utiities ¢ Ping (see page 9-4)
* Route (see page 9-6)
e WiFi Status (see page 9-10)
* Backup Radio Settings (see page 9-12)
¢ Restore Radio Settings (see page 9-12)
%Q RASMan Establishes a remote access service (RAS) connection. 6-10
RASMan
% Reboot Performs a warm or cold boot from the touch screen, as 6-13
e opposed to the keyboard commands.
@ RegBackup Backs up the registry. 8-6
RegBackup
@ RegEdit Allows you to edit the registry and import and export registry 8-1
. keys.
egEdit
@ RegRestore Loads the RegBackup file. 8-6
RegRestore
(11 ScanWedge Enables the Dolphin terminal to interpret as keystrokes data 5-1
Scanwedge received via the decoder, serial port, or IrDA interface.
G SetRAM Allows you to re-set the memory allocation. 11-1
SetRAM
Suspend Manually puts the terminal into Suspend mode from the touch | 6-14
suspend screen, as opposed to the keyboard commands or time-out
settings.
) Sysinfo Displays system information. 6-15

Exiting the Power Tools Main Window

* Scroll down and tap the Exit icon e .

« Tap File > Exit (ESC).

¢ Press ESC on the keyboard.




View Options

The View menu changes the organization of the Power Tools main window and is located at the bottom

of the screen. A checkmark appears next to the selected view.

This menu enables you to choose between:

* Small Icon View
* Large Icon View (Default view)

e List View

Additional Dolphin Power Tools

Small Icon

v Large Icon
List

Detail
File | ¥iew|Help

Detail View (This view displays a description of the Power Tool in a column to the right of the name.)

These Power Tools are in the Dolphin terminal but do not appear on the Power Tools main window.

Name Function Storage Location Access Location Page

Autolnstall Installs CAB files after a \IPSM \IPSM\AutoInstall 4-8
hard reset.

AutoRun Programs which \IPSM \IPSM 4-1
applications launch at
startup.

BTPrint Prints to a Bluetooth \Program \Program 12-2
device. Files\Power Tools Files\Power Tools

DeviceConfig | Configures the terminal \IPSM \IPSM 3-1

EZMenu Programs custom \Program \IPSM 10-1
application windows. Files\Power Tools

InstallerCE Stores CAB files after they | \Program You do not launch 4-1
install instead of deleting Files\Power Tools InstallerCE.
them.

IrDAPrintCE Prints to an IrDA device. \Program \Program 12-2

Files\Power Tools Files\Power Tools




Upgrading Power Tools

Dolphin Power Tools come loaded in every Dolphin terminal and are included in system upgrades.

Acquiring Upgrades

Upgrades are available from Customer Support (see page 13-1) or www.honeywell.com/aidc.

Installing an Upgrade to the Workstation

Power Tools upgrades come in the form of an upgrade executable that installs upgrade files to the
workstation. Transfer the appropriate upgrade files to the Dolphin terminal.
Requirements: An active Microsoft ActiveSync connection between a host workstation and the Dolphin terminal.

1. Download the new Honeywell Power Tools and Demos for WM 6.0 Setup.exe to the Program
Files folder on the workstation.

2. Click the Honeywell Power Tools and Demos for WM 6.0 Setup.exe to install.

@ Honeywell Power Tools and Demos for WM 6.0 E|

Honeywe“ Welcome to the Installation Wizard for the

Honeywell Power Tools and Demos for WM
6.0

The Instalation Wizard wil instal the Honeywell Power Tools and
Dermos for WVl 6.0 on your computer. To continue, click MNext,

WARNING: This program is protected by copyright law and
international reaties.

ww. honeywell com/aide

I MNext > I l Cancel I

3. Click Next. If you accept the terms of the license agreement, select | accept the terms...

I Honeywell Power Tools and Demos for WM 6.0 B|

License Agreement

Please read the following license agreement HO n eywe II

carefuly,

END-USER LICENSE AGREEMENT 1 ~
HONEYWELL DEVICE: Dolphin PDTs
IMPORTANT - READ CAREFULLY:

Thiz End-User License Agreement (Agreement) is a legal contract between you (either an individual or a
single business entity) and Honeywesll, Inc. (Honeywell) for the Honeywell Device identified above, which
includes software created by Honeywell and licensed by Honeywell from one or more software licensors
(Honeywell' Software Suppliers).  Such software products created and licensed by Honeywell for the
Honeywell Device, as well as associated media, printed materials and online or electronic documentation, if
applicable, (collectively, the Software) are protected by interational intellectual property laws and treaties
The Software is licensed, not sold. All rights reserved

2SI THE HARKMEYUUEL T PEVICE  Whll ACDEE Th BE ROLIA By THE TEOMMS OF THIS &
@1 accept the terms in the license agreement

O1 do not accept the terms in the license agreement

< Back ” MNext = I l Cancel




4. Click Next.

-i';{'* Honeywell Power Tools and Demos for WM 6.0 §|

Destination Folder

Click MNext to install to this folder, or click Ho n eywe II

change to instal to a different fold%‘

G Install the Honeywell Power Toolks and Demos far WiV 6.0 to:

C:\Program FilesiHoneywel\Power Tools and Demos for WM 6.0%

[ < Back “ Next > I l Cancel

5. Accept or change the installation location then click Next.

I Honeywell Power Tools and Demos for WM 6.0 (X

Ready to Install the Program

The wizard is ready to begin installation. Ho n eywe II

Click Install to begin the installaton,

If you want to review or change any of your installation settings, click Back. Click Cancel to
exit the wizard.

< Back “ Qstall I l Cancel




6. Click Install and the programs begin installing.

@ Honeywell Power Tools and Demos for WM 6.0 (A=l

Installing the Honeywell Power Tools and

Demos for WM 6.0 Honeywell

Features you selected are being instaled.

Please wait whie the InstalShield Wizard installs the Honeywel Power Tools
and Demos far Wi 6.0, This may take several minutes.

Status:

N

7. The following screen appears when the programs have finished installing:

8. Click Finish.

I Honeywell Power Tools and Demos for WM 6.0 @|
Hnneywe“ Installation Completed

The Instalation Wizard has successfully instaled the Homeywel
Power Tools and Dermos for WiV 6.0, Click Finish to exit the
wizard.

ww. honeywell com/aide




Folder on the Workstation

After installation on the workstation is complete, the upgrade files are stored on the workstation at
C:\Program Files\Honeywell\Power Tools and Demos for WM 6.0.

® Device Image

- File Edit View Favorites Tools Help
@Back - () ¥ ) search |1{__ Folders‘ EHAGE]

: Address & C:\Program Files\Honeywell\Power Tools and D«

x

Folders Name
3 [ Honeywell b jiutoi
#2 Auto
=33.29
= () Power Tools and Demos for WM 5.0 %TUE?E

Note: If a Honeywell folder does not already exist in the Program Files folder, the installation creates one.

Device Image A ghostimage of the IPSM upgrade. The contents of this folder should replace the contents
of the \IPSM folder on the Dolphin terminal.
Docs User guides for Demos and Power Tools (including this guide).

EZConfig EXM Files Sample EXM files. These files contain the default configuration settings for Dolphin
terminals with Windows Mobile 6.

Installing an Upgrade on the Terminal

1. Using the appropriate Dolphin communication peripheral for your series, connect the Dolphin termi-
nal to the workstation and ensure that the ActiveSync connection is running.

2. On the workstation, open Windows Explorer and navigate to the \IPsM folder on the Dolphin
terminal.

Back up the terminal’s \1PsmM folder by copying and pasting its contents to the workstation.
4. Then, on the terminal, delete the entire contents of the \IpPsM folder.

5. On the workstation, navigate to the C: \Program Files\Honeywell\Power Tools and
Demos for WM 6.0\Device Image.

6. Copy all items (including the Autolnstall folder).

© File i!!l View Favorites Tools Help

QB& Folders | [fxz]™ |£| ‘\;ﬁ'\?:'Favorites &) 3
Cut Ctri+X

: Addresd
: Copy L Ctrl+C

als and Demaos for Wil 6.0%Device Imageiwmo

Folder x

10

.n'.'n wllai= e

7. Navigate to the \1PsmM folder on the Dolphin terminal and paste.

8. Copy and paste all custom CABs (radio drivers, applications, programs, etc.) to the \IpPsM folder.

a. If you have custom EXM files with settings you want to keep and you want to have the upgrades in the new
EXM files, merge those EXM files with the new EXM files instead of replacing them.

b. Then, paste the merged EXM files to the Dolphin terminal.

1-8



9. When all the files are pasted, cold boot the terminal.

10. The Power Tools upgrade installs during startup.
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EZConfig

Overview

EZConfig is a suite of products that configures Dolphin terminals quickly and efficiently. With the tools in
the EZConfig suite, you can package data on the workstation, then deploy and unpackage that data on
the Dolphin terminal.

Components

There are two main components to EZConfig: EZConfig Editor and EZConfig Client.

EZConfig Editor

Edits and creates configuration and registry documents in the EXM file format for Dolphin terminals. There
are two versions of EZConfig Editor: one for the terminal and one for the workstation.

For details about the workstation editor, see EZConfig Editor on page 2-2.

For details about the terminal editor, see EZConfig Editor on the Terminal on page 2-30.
Capabilities

Both editors:

* Create and modify EXM files—Working with Open EXM Files (see page 2-7)
* Convert INI files to EXM files—Converting Known INI and MNU Files (see page 2-28)

In addition, EZConfig Editor on the workstation
* Generates bar codes from EXM files—Creating Bar Codes (see page 2-21)

EZConfig Client

Decodes the bar codes generated by EZConfig Editor on the workstation. For details, see EZConfig Client
on page 2-34.

Upgrades

EZConfig Editor on the workstation must be installed on the workstation separately from the Power Tools
upgrade. Obtain the Honeywell EZConfig Editor Setup rXX.exe from Customer Support (see page 13-
1) or www.honeywellaidc.com and install it on your workstation.

All components on the terminal-the EZConfig Editor and the EZConfig Client—are installed during Power
Tools and Demos upgrades. For more information, see Upgrading Power Tools on page 1-5.



http://www.honeywellaidc.com

EZConfig Editor

EZConfig Editor creates, edits, and manages EXM files for Dolphin terminals. There is an EZConfig Editor
on the workstation and an EZConfig Editor on the terminal. In the workstation editor, EXM files are edited,
saved, then transferred to the terminal. In the terminal editor, EXM files are edited and saved right on the
terminal; see EZConfig Editor on the Terminal (page 2-30).

EXM Files

The EXM file format is an XML format customized for Dolphin terminals that are comprised of sections
that sometimes contain child sections and keys. Keys contain the values that configure the terminal.

The EXM file format supports a multi-level, hierarchical, tree structure. The terminal reads the highest
level section first and then reads the key values in each section.

EXM files replace INI files for Power Tools and terminal configuration settings. If both an INI file and an
EXM file are present for the same application, the terminal defaults to the EXM file and a warning
message appears at startup. Remove the INI file from the terminal to avoid this warning message.

Types of Configuration Files
There are two types of configuration files in the EXM file format:

Configuration Documents Program and configure the terminal; see Opening EXM Files on page 2-6.
Registry Documents Update and modify the registry; see Registry Documents on page 2-17.

Installing EZConfig on the Workstation

EZConfig Editor on the terminal installs automatically as part of the Power Tools CAB file.
You must install EZConfig Editor on the workstation separately.

1. Obtain the Honeywell EZConfig Editor Setup.exe and save it to the workstation.
2. Double-tap this EXE and follow the installation guide.

3. When installation is complete, a C: \Program Files\Honeywell\EZConfig Editor folderis
EX

created and an EZConfig icon appears on the Desktop .

Sample EXM Files

After you install the new build on the workstation, default EXM files are stored in the C: \Program
Files\Honeywell\Power Tools and Demos for WM 6.0\EZConfig EXM Files folder.

% EZConfig EXM Files M=
. File Edit View Favorites Tools Help l':'
: - —~ " _ \ L —
Qo - © ¥ O seah | Forers | [ [x] Yerawoies @) 37 X ) 4] 1) ([
Address |£5 C:\Program Files\HoneywellPawer Tools and Demas for Wi 6,0NZCanfig EXM Files| I v
Folders = Mame Size Type Date Modi #
H I = Aumlnstall.exm 3 KB EasyXml Configu... 2/22/2008
= (0 Honeywe _ [ sutorun,.exm 44 KB EasyxXml Configu... 2/12/2008
& EZConfig Editor [BBatteryanalyzer exm 2KB Easyxml Configu... 2/12/2008
= [ Power Toals and Demos for Wi 6.0 [@Dermostenu.exm 9KB Easyxml Configu... 2/12/2008
= [ Device Image #|DeviceConfig.esm 20 KB EasyXml Configu... 2/28/2008
= I wmiE [BaEzConfighvenu.exm 15 KB Easyxml Configu.., 2/12/2008
£ AutoInstall #1magebema.exe.config.e... 2KB Easyximl Configu... 2/28/2008
& Docs NetworkMenu.exm 11 KB EasyXml Configu... 2/12/2008
) [ZPower ToolsMenu. exm 12 KB Easvxml Configu... 2/12/2008
= EZCDnﬂg ExM Files . [ = S P, A0 D e eal Cemfinn R R Pornlyl=] b




Use these files as templates to create new EXM files.

Opening EZConfig Editor on the Workstation

After you complete installation, EZConfig Editor is available on the workstation from the Start menu.

Click Start > Programs > Honeywell > EZConfig Editor > EZConfig Editor.

Menu
\‘
Toolbar ~H

» EZConfig Editor
File Edit View Tools Help

Dl | e &

Fey | Value Kep | Value

Menu and Toolbar Options

The menu and toolbar at the top of the window contains many options.

File Menu
Menu Item Description
New Creates a new document. There are two options:
ew ¢ Configuration Document - Creates a configuration file;
Creating New Configuration Documents (page 2-15).
* Registry Document - Creates a registry file in the EXM file format;
Registry Documents (page 2-17).
= Opens an EXM file located on the workstation.
Open = P
Open from Device | Opens an EXM file located on the terminal. The location of the file appears in the title bar
with the word “[Remote]” to identify that the open file is located on the terminal.
Note: Requires an ActiveSync connection between the workstation and the terminal.




File Menu

Menu Item Description
g Saves the open file to the location you select on the workstation.
Save This option is disabled for new and imported files; use Save As instead.
Save As Saves the open file with a new name to the location you select on the workstation.

Save to Device As

Saves an open file to the terminal; see Saving to the Device on page 2-14.
Note: Requires an ActiveSync connection between the workstation and the terminal.

Properties

Associates the EXM file with an application on the terminal; see Associating Applications
on page 2-16.

Create EZConfig
Bar Code

Embeds the open EXM file in an Aztec bar code; see Generating Bar Codes on page 2-
22.

Exit

Closes EZConfig Editor.

Edit Menu

For Section Edit menu options, see Working with Sections on page 2-7.
For Key Edit menu options, see Working with Keys on page 2-12.

View Menu

Menu ltem

Description

View Locks =

Displays an icon over locked sections. For example,

»scanwedge.exm - EZConfig
File Edit View Tools Help

0| =

@ Decode
Centering

The key icon means that th = 4— The lock icon means the section’s
section’s keys are locked. e\> subsections are locked.

Information about locks on subsections and keys also appears in the Status Bar (see
page 2-7).




Tools Menu

Menu ltem

Description

Simplify Document

Note: You cannot
undo this
action!

Simplifies the EXM file, which makes it smaller. Simplifying permanently removes

¢ Disabled sections and keys
e Descriptions
e Bar code settings

When you create a bar code, you can simplify the file embedded in the bar code without
affecting the open EXM file. This reduces the size of the bar code package yet keeps
the disabled sections, descriptions, and bar code settings in the open EXM file for
future reference.

See Simplified (page 2-23) on the Advanced Tab (see page 2-24).

Because the following

menu items execute commands on the terminal, there must be an ActiveSync connection

between the workstation and the terminal.

Launch Associated

If the open EXM file is associated with an application on the terminal, this item is active

Application and launches the associated application on the terminal.
Note: You would use this option after saving the EXM file to the terminal; see Save to
Device As on page 2-4.
*Warm Boot Warm boots the terminal.
*Cold Boot Cold boots the terminal.

*Some settings affect the boot process and these menu items can help you run a test without switching to the

terminal.

Upgrade Remote
INI Files

Launches the tool that converts existing INI files stored on a device to the EXM file
format. For more details, see Converting Known INI and MNU Files on page 2-28.




Opening EXM Files

EZConfig Editor opens EXM files stored on the workstation or the terminal (if an ActiveSync connection
is established).

Opening EXM Files on the Workstation

Click File > Open or the Open toolbar button £ and select the EXM file.

When you select a known MNU or INI file, EZConfig Editor prompts you to convert the file. When you
select Yes, EZConfig Editor imports the file and converts it to the EXM file format. Then, you can click
File > Save As to save the file with the EXM extension.

You cannot save known INI or MNU files in their original format. For a list of known files, see Known INI
and MNU Files on page 2-28.

The preferred conversion method is to use the batch conversion tool and then make your edits to the new
EXM files. For details, see Converting Known INI and MNU Files on page 2-28.

Opening Remote EXM Files

The workstation and the terminal must be connected via ActiveSync!

EZConfig Editor can open EXM files located on the terminal so that you can make edits to the terminal’s
configuration real-time.

When the terminal and workstation are connected by ActiveSync, click File > Open From Device and the

remote open window opens.
™ Remote File Open g@@

File Type: |". =0 ﬂ

=l s

Autarun, exm
Demoshenu. exm
DeviceConfig. exm
Easphd e exm
Imagel emo.exm
FrintDremobd enu.exm
R&Skan. exm
RFSettings.exm
Scandemo. exm
Scanwedas exm

< >

ak | Cancel

To open, double-tap on a file or select it and click OK.
Note: You can also open EXM files in the editor on the terminal; see EZConfig Editor on the Terminal (page 2-30).




Working with Open EXM Files

Whether you open an EXM or INI file, EZConfig Editor displays the content in four different sections of
the window.
Displays the file name.

If the file is on the
terminal, the title bar

»scanwedge.exm - EZConfig Editor
File Edit View Tools Help

Displays the root node D= el dlsﬂays the remote
and sections. — ¥3(1 Scanwedge Key Walue path.
. ‘3 Versi 3
Select a section and the e r— Deburn Disabled
gter:g:]s gﬁ%?,asré? ttr?ee g gecod‘e E;;I:d E::E::danthack Speaker Displays the keys in the
" .
Windoe\/ =" erlr?g [rataT erminator 13 selected section.
: § Prefisk.eps 1] T :
. ; extthat appearsinblue
The folders appear in Sulfiskieys 13 b d'?pd
P PrefixlD Dizabled can be eadited.
different colors to SuffilD Disabled
indicate their status. SoundConnect Enabled
MeszzageConnect Dizabled
. - SendMode Wirtual Key
Section: Settings
General zettings that apply to the Decoder, Serial GoadScariv/av
|| Part or D& interface BadScaniv/av
) AcceptEZConfig Enabled
Displays the section ) < > .
nange Zlnd description. Versi _Dlsplays the selected
LRl S , <4—1—key’s name and
urrent version of the configuration file. Do not edit. .o
description.

Status Bar —p|

Section: Settings [ Delete+tdd S & SubSections =2 Keps elby

Status Bar

The Status Bar appears at the bottom of the window and displays information about selected sections and
keys.

Selected Section

ISectioQ: Settings [ Delete+idd Locks: & SubSections =2 Keys Mame [by parent]
Section Name Merge Mode Locks on subsections and keys

See Section Locks on page 2-10.

Selected Key

Kew: Wersion Ellabled Fleid Orly Locks: Na{ne [by parent]

T * iy
Key Name Enabledor Read Only Encrypted Key locked by
Disabled section

See Key Types on page 2-14.

Working with Sections

The EXM file format supports a multi-level tree structure. The section tree appears in the top left quadrant
of the window. The root node identifies the EXM file and “Root” appears in the description.

Sections have a Name and Description and contain keys that appear in the upper right quadrant when
you select the section name. Select a section by clicking on it. You can select only one section at a time.




Edit Menu Options

Select a section click Edit to see the available options.

o3¢+ Gut Ctrl+X
4 Copy Ctrl+C
Delete Del
Disable All Ctrl+D
Insert Section... Ins
Append Child Section...

Menu ltem Description
Rename Activates the section name so that you can rename the section.
Note: You cannot modify the name if the section is locked; see Section Locks (page 2-10).
Cut Cuts a selected section.
Copy Copies a selected section.
Paste Pastes the section that was just cut or copied at the same level as the selected section.

Paste as Child

Pastes the section that was just cut or copied as a child of the selected section.
Note: You can cut, copy and paste sections within an EXM file or across EXM files.

Delete

Deletes a selected section.
Note: Because you cannot undo a delete, consider disabling rather than deleting.

Enable

Sections are enabled by default. This menu item enables sections that were previously
disabled. You can enable a section only if its parent section is enabled.

To enable all the keys inside a section you are enabling, SHIFT + right-click and select
Enable All.

Disable All

Sections are enabled by default. This menu item disables sections and all of its keys.
Disabled sections remain in the file with a gray folder .

7 Autolnztal
27 AutoRun 501

@-n <

If you disable a section tﬁat has child sections, all of its child sections (and the child section
keys) are disabled automatically. The child section folders are also in gray.

When reading the EXM file, the terminal behaves as though disabled sections are not there
and moves on to read the next enabled section.

Disabled sections can be removed from the EXM file permanently using the Simplify
Document (see page 2-5) option. If you want to keep disabled sections in the EXM file on
the workstation but not in the file deployed to the terminal, use the Simplified option (see
page 2-23) when creating the bar code.




Menu ltem Description

Insert Section This menu item inserts a new section. You can also press the Insert key (INS).

Append Child This menu item adds a new child section to a selected section. The new child section is
Section inserted below the previous section.

Modifying Section Names

To change a section name, double-click on the folder and type in the new name or select Rename on the
Edit menu. Type in the new name and press ENTER.

Note: You cannot modify the name if the section is locked or disabled; see Section Locks (page 2-10).

Modifying Section Descriptions

Descriptions are not required to process key values but do help document the EXM file and often contain
valuable information. If you want to modify a section description, select the section, click inside the section
description, and begin typing. You cannot modify descriptions of locked sections.

Moving Sections

To move sections within an EXM file, use the drag and drop method. By default, sections are dropped at
the same level in the tree.

For additional functionality when dragging and dropping, press and hold:

* ALT to drop a section as a child section.
e CTRL to copy a section and drop the copy at the same level in the tree.
e CTRL + ALT to copy a section and drop the copy as a child section.

Note: You can select only one section at a time; you cannot use SHIFT+Click or CTRL+Click to select more than
one section.

To move sections between EXM files, open two instances of EZConfig Editor and drag and drop sections
between them. When dragging, a copy of the section is dragged to the new file. When dropping, drop the
section directly on top of the section you want it to be a child section of.

Note: To drop the first section into a new file, press and hold the ALT key and drop the section on the root node. (All
sections must be child sections of the root node.)




Section Locks

There are different types of locks on sections. The status bar indicates what type of lock is applied to a

selected section.

Lock Type Status Bar Description Effect
Indicator
Name Lock Name [oy parert] The section name is * Section Name and Description cannot be
locked. modified.
Key Lock = e All keys are locked. ¢ Key Names and Descriptions cannot be
L= modified.
* Keys cannot be added, moved, or deleted
within the section.
Subsection & SubSectons All immediate subsections | ¢ Immediate subsection Names and
Lock are locked. Descriptions cannot be modified.
¢ |mmediate subsections cannot be added,
moved, or deleted.

Note: All locks are applied to each individual section and are not recursive. Only text that appears in blue can be

modified.

Section-Level Merge Modes

EXM files ship with section-level merge modes already defined according to section content. Merge
modes determine how section information is handled when an updated EXM file is deployed to the
terminal where an existing version of that EXM file is stored.

Merge modes are indicated by folder icons and in the Status bar.

Mode Description Merge Effect
1 Delete + Add | Deletes non-common children elements (i.e., subsections, and keys) in | Exclusive
the target file, then adds the new information from the bar code.
Basically, the new section replaces the old section.
This is the default merge mode for new sections.
== Disable + Disables non-common children elements (i.e., subsections, and keys) in
Add the target file, then adds the new information from the bar code.
Note: Disabled sections and keys removed from the simplified bar code
end up as disabled in the target file.
s Add Only Adds new information (sections and keys) to the existing section. If this | Inclusive

is a brand new section, the new section is added to the existing EXM

file.

Note: Disabled sections removed from the simplified bar code are not
modified in the target file.




To change section-level merge modes, select a section and right click.

= NewDocument.exm - EZConfig
File Edit View Tools Help

[~

=7 MewDocument Key

Rename
Cut

Copy

Delete

Disable All

v Set to Delete + Add
Set to Add only
Set to Disable + Add

Thesrt Sarctinmn. .

The folder colors change immediately after selection.




Working with Keys

Keys have a Name, a Description, and a Value and reside inside sections. For specific key values, consult

the chapters of this user’s guide that describe the EXM file you're attempting to edit.

Edit Menu Options

Select a key and right-click or click Edit to see the available options.
File Tools Help

Walue

= ;'h C
Rename s E Rename
cut i Cut Ctrl+X
Dath erming (:0[:)\,||I E COp\f Crl+C
Frefutess The same options g
uffisk.eps
PrefislD <4———appear on both —»
Suffi<lD menus.
Sgul:dconnz Delete L Delete Del
MezzagelCor
SendMode
GoodScani . i
BaogscaC:C\fe Disable Disable Ctrl+D
AcceptEZLe Insert Key... InsertKey... Ins
Menu Item Description
Rename Activates the key name so that you can rename the key. Rename is disabled if the key
is locked or disabled; see Key Types (page 2-14).
Cut Cuts a selected key.
Copy Copies a selected key.
Paste Disabled; keys can be pasted only as children of a section.

Paste as Child

Pastes the key just cut or copied in the selected section. Keys are not multi-level; all
keys paste at the same level within a section.
You can cut, copy and paste keys within an EXM file or across EXM files.

To enable a key, its parent section must be enabled.

Delete Deletes a selected key.
You cannot undo a delete; you might want to consider disabling rather than deleting.
Enable Enables keys that were disabled. When a key is enabled, the client application can

read and apply its value. When you enable a key, make sure to specify a value for that
key; do not leave it blank.




Menu Item Description

Disable Disables keys.
Disabled keys have key values in black. Enabled keys have key values in blue.

Key Walue
Enable 1
SSID
PowerMode 1
EPSParm 1
MetworkType 1

.\'Ehannel 10
DHCP 1

The terminal does not read disabled keys and disabled keys are removed if the file is
simplified; see Simplify Document (page 2-5).

Because many key values are 1 for enable and 0 for disable, remember that disabling
key means that the terminal behaves as if the key is not there when reading the file,
NOT that the key’s value is set to disabled. The terminal simply moves on to read the
next enabled key.

QO

Insert New Key This menu item inserts a new key above the selected key.
Note: You can also press the Insert key (INS).

Modifying Key Names

To modify key names, double-click on the key name or select Rename on the Edit menu. Type in the new

name and press ENTER or TAB.

Note: You cannot modify the description if the key is locked; see Key Types (page 2-14). Only text that appears in
blue can be modified.

Modifying Key Values

You can modify a key value only if its text appears in blue. In that case, double-click on the value or select
the key and press ENTER. Type in the new value and press ENTER or TAB to save.

Modifying Key Descriptions

Descriptions are not required to process key values but do help document the EXM file and often contain
valuable information. To modify a key’s description, click on the key, then click in the key description area.
When the cursor is active, you can type in the text.

Note: You cannot modify the description if the key is locked; see Key Types (page 2-14).

Moving Keys

To move keys within an EXM file, use the drag and drop method. Press and hold the CTRL key to drag
and drop a copy of the key to the new location.

Note: You cannot move a key if it is locked by its section.

To move keys between EXM files, open two instances of EZConfig Editor and drag and drop keys
between them. When you select the key and drag, a copy of the key is dragged to the new file. In the new
file, drop the key in the key area of a selected section; keys are always dropped at the same level within
a section.




Key Types

When a key is selected, its properties display in the Status bar.

Lock Type Status Bar Description Effect
Indicator
Name Lock e (by parent Keys are locked by the * Name and Description cannot be
¢ Keys cannot be added, moved, or
deleted within the section.
Hame The key name is locked * Name and Description cannot be
individually. modified.
e These keys can be moved.

Read Only Fread Onip Read-only keys cannot be * Name, Description, and Value cannot be
modified in any way. They modified.
appear in red. * Keys cannot be added, moved, or

deleted within the section.

Encrypted E—— Key’s value appears as Note: Encrypted keys are also stored
asterisks (*) for added encrypted in the EXM file. If you open
security. the EXM file in a text editor, you won't

' see the data as clear text.

Note: Locked and Read Only properties are not recursive. Properties are applied to each individual key. Only text

that appears in blue can be modified.

Saving to the Device

You can save EXM files directly to the terminal when there is an ActiveSync connection between the
terminal and the workstation. Select File > Save to the Device As and the Save Remote File window

opens.

Filehame:  |Scariwedge.exm
+- Application Data
Connkdgr
+- IPSM
+- My Documents
+- profiles
+/- Program Files
Temp
+- Wwindows
< | i
Ok | Cancel

Select the location on the terminal where you want to store the file and click OK. The file is downloaded

directly to the terminal via ActiveSync.

Note: EXM files for Power Tools must be stored in the \IPSM folder.




Creating New Configuration Documents

To create new EXM files that are configuration documents, you can open an existing EXM file and save
it with a new name or create an EXM file from scratch.

1.

Click File > New > Configuration Document. The root node is created and appears as the top level
section. All sections must be at least one level down from the root node. The name of the root node
is always the same as the filename.

» NewDocument.exm, - EZConfig Editor
File Edit View Tools Help

. Ol (&
The terminal reads SR T
root node first. [ NewDocurent | = EkE

The Description 3
says “Root” to —1Root: NewDocument I
indicate that this is
the root section.

Section: MewD ocument [ Deletessdd

Note: You can also create registry documents in the EXM file format. For details, see Registry Documents on page

2.

2-17.

To create the first subsection, select the root node, right-click, and select Append Child Section.
Insert Section is disabled because you cannot insert sections at the same level as the root node.

Enter a Name and a Description and click OK.
The name is required, the description is optional.

To add a new section at the same level, right-click and select Insert Section.
To add a new section one level down, right-click and select Append Child Section.

To add keys, select a section, right-click in the key value section, and select Append Key.

Enter the Name, Value, and Description and click OK.
The name is required, the description is optional.

Continue adding sections and keys.
If necessary, associate this EXM file with an application; see Associating Applications (page 2-16).

Click File > Save As to save the file.
Save is disabled so that you save the document with a name other than “NewDocument.exm.”




Associating Applications

The Properties function associates an EXM file with an application on the terminal. The associated
application launches after EZConfig Client decodes the bar code containing the EXM file.

For more information, see Creating Bar Codes on page 2-21.

While the EXM file is open, click File > Properties or the Document Properties toolbar button =,

% Document Properties E“E|EJ

Agzociated Application

Path: |\program filez\pawer toolzhscanwedge.exe

Arguments: |a’restart Jewm Zhlename

= [ wiait Until Finizhed

Ok | Cancel

Field

Description

Path

Enter the location of the EXE on the terminal.

Arguments

Enter the command line argument you want applied when the application launches.
When an application is entered in the Path field, the following command line appears as
the argument: /exm %filename.

Enter additional command line arguments (see Command Line Arguments on page 2-
37) next to /exm %filename in this field.

“Y%filename” means that the value immediately after the “%” is variable and the file name
will be replaced with the remote path entered on the Bar Codes tab; for more information,
see Remote Path on page 2-23.

Execute

Tells EZConfig Client to launch the application after decoding the bar code. Execute
selects automatically when an application is entered in the Path field.

You cannot de-select Execute for configuration documents.
You can de-select Execute for registry documents; however, EZConfig Client cannot

update the registry unless Execute is selected. For more information, see Default
Application Association (page 2-17).

Wait Until
Finished

Tells EZConfig Client to wait until the associated application is finished processing before
finalizing.




Registry Documents

EZConfig Editor creates registry documents in the EXM file format and also opens existing REG files and
converts them to the EXM file format. EZConfig Editor cannot save registry documents in the REG file
format.

Updating the Registry on the Terminal

To update the terminal’s registry, you must

* Create an EXM file that is a registry document—Creating Registry Documents (page 2-18),
* Create a bar code package from that EXM file—Creating Bar Codes (page 2-21), and
* Scan the bar code with the terminal

By default, EZConfig Client on the terminal updates the Windows registry immediately after decoding the
bar code.

Default Application Association

By default, registry documents are associated with EZConfig Client. While a registry document is open,
click File > Properties.

B Document Properties EoX
Aszzociated Application
Fath: | 4 —
Arguments: |
[ Execute r
’Tl Cancel |

Execute must remain selected for EZConfig Client to update the registry after decoding the bar code. If
Execute is not selected, the registry document is deployed after decoding but the registry is not updated.




Creating Registry Documents

1.

In EZConfig Editor, click File > New > Registry Document.

» NewDocument.exm - EZConfig Editor
File Edit View Tools Help

SEEL I

ument Key | Tupe Walue
=ty " CLASSES_ROOT
= HKEY_CURREMT_USER
= HKEY_LOCAL_MACHINE

||Root: NewD ocument

Section: MewD ocument [ Delete+tdd

The new document contains the three top-level sections in a registry. These sections are locked and
caBnot be changed. You can add subsections to each section and then add keys to those
subsections.

Click File > Save As.

Choose the name and location and click Save.
You cannot save the document as a .reg file; you must save it as an EXM file.

To add sections, select one of the registry levels, right-click, and select Append Child Section.
Enter the section information, and click OK.

= @" MewDocument
--=h HKEY_CLASSES_ROOT
L= 5 ection
=1 HKEY_CURREMT_USER
=0 HKEY_LOCAL MACHIME

For more information about adding sections, see Working with Sections on page 2-7.

To add keys to the new section, select the section, and right-click in the key value area.
For details, see Adding Registry Keys on page 2-19.

Continue adding sections and keys.

Save the file.




Adding Registry Keys

To add a key, select a section, and right-click in the key area of the EZConfig Editor window.

8 Insert Registry Key

=

Hame: |Test Key

Fegistry Value Type: |F|EG_SZ j

Walue:  [n01.123 456001

Desc:

Ok | Cancel |
% |

Field Description
Name Enter the key’s name.

Registry Value Type

Select the registry type from the drop down list. This value appears in the Type

column.
Value Enter the key’s value.
Desc Enter a description for the key; descriptions appear in the lower half of the EZConfig

Editor window when the key is selected.

When you click OK to save the key, the data appears in columns in the key area of the EZConfig Editor

window.

Key Type Walue
TestKey REG_SZ 001.123.456.001

Processing Registry Documents on the Terminal

After EZConfig Client updates the registry, the EXM file itself is deployed to the location entered in the
Remote Path (page 2-23) field on the Bar Codes Tab (page 2-22).

5

+ /4 |File Explorer @l &F ox 328 9

My Device » Name |

[ Application D...
|51 ConnMagr

IPSM

1My Documents
[ profiles

|1 Program Files
=1 Temp

1 Windows

[#Defaultsettings  8/30/05 3798

Note: EXM files appear with an icon on terminal windows.




If you do not want to store the registry EXM file on the terminal after updating the registry, select the
Temporary (page 2-25) option on the Bar Codes Tab (page 2-22).

Persistent Registry Documents

If you want to update the registry during every cold boot, create a registry document in the EXM format,
save it to the terminal in the \IPSM\AutoInstall folder, and cold boot. The registry settings in the EXM
file will load during startup.

Note: Of course, if you want to save a registry file but not load it every startup, simply store the registry EXM file in
the \IPSM folder.




Creating Bar Codes

EZConfig Editor embeds EXM files in bar codes. The EZConfig Client on the terminal decodes the bar
code and deploys the data. Using bar codes quickly and easily configures Dolphin terminals without an
IrDA, ActiveSync, or network connection to a workstation.

Document Types

EZConfig Editor produces two kinds of EXM files: configuration documents and registry documents. Both
can be embedded in bar codes and processed by EZConfig Client on the terminal.

Configuration Documents

EZConfig Client deploys the EXM file in the terminal. If an EXM file is associated with an
application, EZConfig Client deploys the data to that application for processing; see
Associating Applications on page 2-16.

Note: The DeviceConfig.exm file must be associated with DeviceConfig.exe to be processed
appropriately on the terminal.

Registry Documents
EZConfig Client updates the registry immediately without launching another application.

Bar Code Type

EZConfig Editor creates an Aztec bar code; for example,

Time and Date Stamp

EXM files are stamped with the time and date the moment EZConfig Editor creates the barcode.

Bar Code Size and Number

The amount of data in the EXM file determines how many bar codes are generated and the physical size
of each bar code. More data means more bar codes and larger bar codes.

EZConfig Editor offers four ways to control how many bar codes are produced and adjust the size of each
bar code:

1. Set byte size limits on how much data each bar code can contain—see Max Barcode Size on page
2-24.

2. Split the data across a specified number of bar codes—see # Bar codes to generate on page 2-23.
Simplify the EXM file in the bar code—see Simplified on page 2-23.

4. Scale the bar codes on the bar code sheet—see Bar Code Scaling Factor on page 2-26.




Bar Code Sheet

EZConfig Editor produces a bar code sheet that contains the generated bar codes. Bar code sheets can
be printed from a laser printer, copied to the clipboard, and saved as an HTML file; see Printing and
Saving Options on page 2-26.

In addition, individual bar codes can be saved as TIF or PNG graphic files that can then be emailed and
printed; see Bar Codes Tab on page 2-22.

Generating Bar Codes

When creating a bar code, EZConfig Editor automatically encrypts and compresses the data in the EXM
file. To generate a bar code, click File > Create EZConfig Bar Code OR the Create Bar Code toolbar

button while the EXM file is open. EZConfig Editor generates a bar code or codes. The Bar Codes tab
window opens displaying the details of the bar code package generated.

T EZConfig Bar Code =] 3

Bar codes IAdvanced]
Displayr | 1 = (363 bytes]
b iy e ks Fiemote Path

|\ipsm\‘31:anwadge Exm s

Options
" Full Contents

(& Simplified [removes all descriptions
and disabled elements)

Copy to Clipboard Save Save All Frint.

Package Size: 1699 bytes  CompressionOn  Enciyplion:0On Bar Codes: 2

The Bar Codes and Advanced tabs offers several processing options.

Note: The number of bar codes produced depends on the amount of data present in the EXM file. The more data
present, the more bar codes generated. You must scan all bar codes to deploy the package!

Bar Codes Tab

The Bar Codes tab previews and customizes generated bar code(s).

Field/Option Description

Display Indicates which bar code is displayed in the preview area; the default is “1,” the first bar
code in the package. If more than one bar code was generated, you can use the up and
down arrows to scroll through the bar codes.

(__bytes) Displays the exact byte size of the bar code displayed in the preview area.
Total Package Size (page 2-26) is displayed at the bottom of the window.
Note: The sum of bar code size is typically larger than the package size.




Field/Option

Description

Remote Path

Type in the location and filename where the EXM file should be deployed on the terminal.
For instance,
\ipsm\deviceconfig.exm

Tap the browse button L to navigate to the location on the terminal. Your ActiveSync
connection must be active.

Full Contents

Includes the full content of the EXM file in the bar code, without simplifying.

Simplified

Simplifies the EXM file in the bar code, which removes disabled sections, description
information, and bar code settings (if any), which decreases the size of the bar code. The
open EXM file is not simplified.

Simplified is selected by default.

The differences in total package size are displayed in the Package Size (page 2-26) field.

Individual bar code size can be seen in the Display (page 2-22) field.

# Bar codes to

This is active only if the Always use minimum # bar codes (see page 2-24) is hot

generate selected. When this slider is active, you can move the slider toward minimum or
maximum to change the number of bar codes generated. As you move the slider, you'll
see the number of bar codes in the counter at the bottom of the window BaiCed=5 and
you’ll notice the graphic of the bar code in the preview area change.

Copy to Copies the bar code displayed in the preview area to the clipboard.

Clipboard Use this option to paste the bar code into another application.

Save Saves the bar code displayed in the preview area as a graphic file as a .png or .tiff.
By default, the name of the graphic file is the same as the name of the open EXM file.
You can enter a different name when saving.

Save All Saves all bar codes in the package as individual graphic files.
By default, the graphic files are saved with the same name as the open EXM file with a
number at the end to distinguish the individual graphic files from each other.

Print Opens the printing window where you can select print options and print the bar code

package. For details, see Printing and Saving Options on page 2-26.




Advanced Tab

The Options tab contains settings that tell EZConfig Client how to process the EXM file on the terminal.

EZConfig Bar Code

Bar codes .&dvanced]

Bar code options

tax bar code size: I Full screen progress dialog

1500 EI:

v Always uze minimum # bar codes I ‘warm boot device after finished

I lse custom passward:

Dreployment options IF already exists, deploy:

" Replace remote file (v Always

. ) : ] " Only if newer
» Merge each zection with the ones in remote file g
" Temporary [remove file after finighed) oy

|v Persist bar code settings

Package Size: 1089 bytes  Compression:On Encryption:On Bar Codes: 1

Field

Description

Bar Code Options—This section determines some of the basic bar code parameters.

Max Barcode
Size

Set the maximum amount of data (in bytes) one bar code can contain. The lower the
number of bytes, the smaller the bar code.
* On the Bar Codes tab, bar code size appears in the Display field (see page 2-22).
e The total number of bar codes the are created as a result of the max bar code size
limit appears at the bottom of the Advanced window; see Bar Codes (page 2-26).

Always use
minimum # bar
codes

This option is selected by default. It calibrates the data so that the minimum number of bar
codes are used. When this option is selected, the number of bar codes slider on the Bar
Codes tab is disabled.

Use custom
password

This option enables you to password-protect the bar code you’re creating.

Select this option, then enter the password in the field provided. You will be able to see the
password when you enter it; however, you will not be able to see the password again once
you close the window because the password will be encrypted.

If you password-protect the bar code, EZConfig Client on the terminal will prompt you to
enter that same password on decoding.

Full screen
progress dialog

This option runs the deployment progress dialog box on the terminal in full screen mode
so that the user cannot open another application while the bar codes are being deployed
on the terminal.

Warm boot after
finished

This option automatically launches a warm boot on the terminal after the bar code is
deployed. Use this options with EXM files that contain application information requiring a
warm boot to take effect, such as registry settings.

Deployment Options—These options determine how to deploy the EXM file on the terminal.
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Field Description

Merge each Deploys information according to the section-level merge mode settings; see Section-

section... Level Merge Modes on page 2-10.

(Default If already exists, deploy:

lecti ¢ Always—Select to always use the section-level merge mode settings.

selection) * Only if newer—Select to use the section-level merge mode settings only if the sections
are newer than the existing file.

Temporary Deploys the EXM file temporarily. The settings in the EXM file are applied, but the file does

not remain in the system after EZConfig Client is done.

If the terminal contains a previous EXM file with the same name, the previous EXM file is
preserved.

If already exists, deploy—This section determines how the EXM file will be deployed if there exists on
the terminal an EXM file of the same name in the same location.

Replace remote Replaces the existing file; no section-level merge modes are applied.

file If already exists, deploy:

* Always-Select to always replace the existing file.

* Only if newer—Select to replace the existing file only if the file in the bar code is newer
than the existing.

* Never—Do not deploy the new file; this preserves the existing file.

* Prompt—EZConfig Client asks the user if they want to overwrite the existing file during
deployment.

Persist Bar Code Settings

Stores the settings from the Options, Bar Codes, and Web Page tabs within the EXM file so that the same bar
code settings are applied the next time a bar code is created. This increases the size of both the EXM file and
the bar code(s).

If the Simplify option is selected, bar code setting information is not included in the bar code but remains in the
open EXM file.




Information at the Bottom of Tab Windows

I Package Size: 651 bytes  Compression:0On  Encryption:On  Bar Codes: 1 I

Field Description

Package Size Displays the total size of the bar code package. This number changes with
simplifying.

Compression On Notifies you that compression and encryption are both on.

Compression and encryption are always on by default. EZConfig Editor uses 128-bit

Encryption On encryption automatically.

Bar Codes Displays the total number of bar codes generated. This number changes as you
move the slider on the Bar Codes tab.

Printing and Saving Options

On the Bar Codes tab, when you click Print, a bar code printing window opens offering you a number of
printing options.

8 EZConfig Bar Code Printing

EZConfig Bar Code Sheet

v

Header  |[EZCarfig Bar Code Sheet Bar code scaling factar: 2 =]

Footer: |Hand Held Products Save... | Presiew... |

Package Size: 1699 bptes  CompressionOn Enciyption:On  Bar Codes: 5

Field/Option Description

Preview Area This is the largest section of the tab window and displays a preview of the bar code
sheet. Use the scroll bars to see all the bar codes.

Header Type in a custom header for the page. “EZConfig Bar Code Sheet” is the default
header.

Footer Type in a custom footer for the page. “Hand Held Products” is the default footer.

Bar Code Scaling Adjusts the size of each bar code by scaling all of them up or down, which
Factor determines how many bar codes can fit on each page. This does not change the
amount of data in each bar code, just the size of the bar code on the page.




Field/Option

Description

Save

Saves the bar code sheet as an HTML file.

Preview

Click to see a print preview.

A Print Preview

2| = Page[t o1 = % | B B [75% | Hep | Close

EZConfig Bar Code Sheet

Hand Held Products

Click Print on this window to print your bar codes.




Converting Known INI and MNU Files

EZConfig Editor contains a batch conversion tool that converts known INI files on the terminal to the new
EXM file format.

EZConfig Editor pulls INI files from the \IPsM folder of a remote device, converts them to the EXM file
format, and saves both original INI files and the converted EXM files in folders created on the workstation.
You don’t lose your original INI files in the conversion.

Note: You must have an ActiveSync connection between the workstation and the device to use this tool.

Known INI and MNU Files

e *Autorun.ini

* RASMan.ini

* Scanwedge.ini

* RFSettings.ini

* ImageDemo.ini

e ScanDemao.ini

e *Any EZMenu file (INI or MNU)

*These files must be converted using this tool to run properly on Dolphin terminals.

Converting Files

1. In EZConfig Editor on the workstation, click Tools > Upgrade Remote INI Files. You receive a
warning message describing what is about to happen.

This process is intended to perform a batch upgrade of al the INIs and Menu files found in 4IPS,

!
A corresponding to version 2.8 of the Utlls and Demos, Do you want to continue?

Yes s} ‘

2. Click Yes and EZConfig Editor retrieves remote INI files on the terminal and displays them in a list.

&8 Upgrade Remote INIs

Fleaze zelect the remote files to upgrade:

These are the INI 4PSMYRASMan ini

. SPSMYAUtoR un.ini
files _found- Select UPSMYScandemo.ini
the files you would YPSMYRFSettings.ini
||ke to convert. SPSkYPrntD emobd e ini

SPSMAS canwedge.ini
HIPSMSUtilsk enuini

SPSMSDemosMenu.ini
SPSkYmagelemo.ini

SHIFT + click to
select more than
one file to convert.

This is the location . .
on the workstation Lacation for the upgraded files and backup of the original files: Click this Browse

where the original N E—— . button to select
. ] gram FileshHand Held Products'Power Tool: and Demos\Device ImagehC - L
and converted file e another location.

will be stored. ’—|
Ok Cancel |

3. Select the files and the location on the workstation for the files. The default location on the
workstation is:
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6.

C:\Program Files\Honeywell\Power Tools and Demos for WM 6.0\Device
Image\Converted Files\Upgrade X.

The X increases by one each time you run a batch conversion.
When you click OK, the conversion runs.

EZConfig Editor creates two folders inside the Upgrade X folder: Converted EXMs and Original

INIs.
% Converted EXMs CEX
. File Edit View Favorites Tools Help "
@ Back - (L, 5 - gearch [ Folders E' Iﬂ 3 Favorites 40 % x n Iﬂ 4= .j
Address |23 C:\Program Files\Hand Hald Products'Dalphin Paveer Tools and Demos'Device ImagehConverted Files\Upgrade 024 v
Folders x IJj.lélme Size  Type Date Modify
[ AutoRUn exm 6 KB Easyiml Configu... ©/12/2006
T :' I—iand HelE e e DEmDSMEﬂu.EXm 7 KB Easy¥ml Configu... 6/12/2006
= D_olphln. Poer Tools and Demnos g ImageDerma.exm 1KB EasyXml Configu... 6/12/2006
=) Device Image @PowerTDolsMenu.exm B KB Easyxml Configu... 6/12/2006
=) Converted Files ZPrintDematenu.exm 7KB Easyx¥ml Configu... 6/12/2006
-2 Upgrade 01 AR ASMaN Bxm 3KB Easyxml Configu... 6/12/2006
=53 Upgrade 02 [@BRFSettings.exm 1KB Easyxml Configu.,. 6/12/2006
8] Corverted EXMs @Scandemu.exm SKB Easyiml Configu... 6/12/2006
=) Original INIs [ Scanvvedge, exm 13 KB Easyxml Configu... 6/12/2006
B2 ppc
E-) wm
|-) Doce
1) EZConfig Editor w
< > & >
9 ohijects (Disk free space: 8.75 GB) 46.5 KB 4 My Computer

Note: An Upgrade X folder with these two subfolders is created every time you run a conversion.
Upgrades do not save over each other.

Check each converted EXM file in EZConfig Editor.

Note: Even though conversion is complete, you have not yet upgraded your terminall The old INI files remain in their

original location on the terminal.

Upgrading Dolphin Terminals

Once you approve of the converted EXM files, you must transfer them to the Dolphin terminals manually.

1.
2.

Delete the old INI files stored in the terminal.

Follow the steps for installing an upgrade on a Dolphin terminal (see Installing an Upgrade on the
Terminal on page 1-8) but don’t cold boot yet.

Note: You want to install an upgrade to make sure that you have the latest versions of Autolnstall.exe,
Autorun.exe, and EZConfig Editor on the terminal.

Transfer the new converted EXM files to the terminal and say yes when you are asked to replace the
existing files.

Cold boot the terminal. The new, converted EXM files install during Autolnstall.




EZConfig Editor on the Terminal

EZConfig Editor on the terminal edits and creates EXM files in the terminal and contains the same basic
functionality as the editor on the workstation.

Accessing EZConfig Editor

R

g EZConfip  Autolnstal
Client Editaor
Autorun DemostMenu DeviceConfig
EZConfiy  ImageDemno  Metwaork
Menu Menu
= 2 2 M
EXM| EXM| EXM|

File ¥iew Help

The EZConfig Utilities window provides access to both the EZConfig Editor and the EZConfig Client (see
page 2-34) as well as the EXM files on the terminal.

Opening EXM Files

* Tap directly on an EXM file to open it in EZConfig Editor.
* Tap the EZConfig Editor icon to open EZConfig Editor. (Then tap File > Open to open an EXM file.)

* In File Explorer, navigate to an EXM file and tap once on the file & to open it in EZConfig Editor.

Sections appear in the top half of
the window.

Keys appear in the bottom half of the
window.

Enabled keys have a checkmark.
Disabled keys have a blank box.

Connections
Eeam 4

& Radio I\Eanager
- S
(3 TcPIp
=3 Security
-3 Supplicant
22 Profilel -

Key | Walue

[Enatle an

Poweriode Liizablad

[CJEPSParm 1

[CCriwertame DSFLTR_SDIOBGE861

] D

File Edit ¥iew Tools Help €——————

Disabled sections appear in gray.

The menus contain the same options as the
menus in EZConfig Editor on the workstation.




Available Menus
The menus in the Command bar contain the same items as the menus in the EZConfig Editor on the
workstation.

File Menu For details, see File Menu on page 2-3.

Note: The one difference in the file menus is that you cannot generate bar codes from
EXM files on the terminal.

Edit Menu The Edit menu pops up when you tap and hold on a section or key.
For details, see Edit Menu on page 2-4.
View Menu This menu enables you to view the locked icon over locked section folders.
Tools Menu For details, see Tools Menu on page 2-5.
Editing Sections

Modifying Text
To edit a section name or description, you have three options:

1. Select the section and tap Edit > Modify.
Select an item and press the ENTER key.
Tap and hold on the section name, then select Modify on the Edit menu that pops up.

y  Modify
Copy  {Ctrl+0C)

Disable {Ctrl+D} All

Sy v Set to Delete + Add
Wk Set to Add only
Set to Disable + Add

Key [ /alue | Description |«
Wersion 3 Current verl=
[¥]Debug 0 Enable and [
Sound 1 Enables or [
Leds 1 Enable and

<

[w]DataTerminator 13 Specifies th
0] D

2. All three options open the Edit Section window.

Cancel

3. Tap inside the Name or Description fields and edit the text.




4. Tap OK to save changes. (You can also press the ENTER key.)
Tap Cancel to close the window without changes.

Moving Sections

You cannot drag and drop to move sections in the tree. Use the Cut, Copy, Paste, and Paste as Child
items on the Edit menu to move sections.

Note: The Paste function pastes sections at the same level they were cut by default.
Editing Keys

Modifying Text
To edit a key’s name, value, or description, you have three options:

1. Select the key and tap Edit > Modify,
Select the key and press the ENTER key, OR
Tap and hold on the key’s name, then select Modify on the Edit menu that pops up.

Key

Yersion
Debug
Sound
Leds

Disable {Ctrl+D}

Walue | Description |«

Modify
Copy  {Ctrl+0C)

DiataTarminator
0] Tl
File Edit Yiew Tools Help

Marne: |Descripti0n |

Walue:

Eattery Maoniter Utily

Description:

2. Tap inside the Name, Value or Description fields and edit the text.

3. Tap OK to save changes. (You can also press the ENTER key.)
Tap Cancel to close the window without changes.

Moving Keys

You cannot drag and drop to move keys. Use the Cut, Copy, and Paste as Child items on the Edit menu
to move keys.




Launching Associated Applications
The Tools menu contains an item named Launch Associated App.

Key | Walue | Diescription |:

Wersion 3 Current ver=
Debug Launch Associated App
Sound Simplify Document

Leds

DataTermj Cold Boot

| Warm Boot

File Edit Yiew Tools|Help

Launch Associated App is enabled only when there is an application associated with the EXM file.
Selecting this item automatically saves the open EXM file and launches the associated application while

the EXM file remains open.
To see the associated application, tap File > Properties.

Associated Application:

Path:

|\pr0gram files\power toolstdeviceco |

Args:

|,‘exm %afilename |

[ wwait Until Finished

Cancel

The Path field contains the launch location of the application.
The Args field contains any command line arguments to execute when the application launches.

For more information about associating applications, see Associating Applications on page 2-16.

Example 1: You've saved changes to an open DeviceConfig.exm file.

To a_pplg those changes immediately, tap Tools > Launch Associated App. Because the
DeviceConfig.exm file is associated with DeviceConfig.exe by default, DeviceConfig launches and
applies the settings in the DeviceConfig.exm file.

Example 2: You’ve saved changes to an open registry document.

Because registry documents are always associated with EZConfig Client, tapping Tools > Launch
Associated App updates the registry. EZConfig Client always updates the registry when launched
from an EXM file that is a registry document.

Example 3: You've saved changes to an open ScanWedge.exm file.
And that ScanWedge.exm file has the following parameters as the associated application:

Path: \program files\power tools\scanwedge.exe

Args: /restart
Tapping Tools > Launch Associated App refreshes ScanWedge with the new settings.




EZConfig Client

EZConfig Client decodes bar codes created in EZConfig Editor and deploys the data in the terminal. In
addition, if the EXM file in the bar code is associated with an application, EZConfig Client launches that
application, which then processes the decoded data.

EZConfig Client decodes bar codes with 40-bit and 128-bit encryption.

Storage Location

The EZConfig Client executable is stored in the \IPsSM folder.

|1 Imaging Profil...
_ﬁ‘.}nutolnstall

1/1/05 108K

[ Autolnstall 1/1/05 269K
4 Autorun 1/1/05 450K |=
[ Autorun 1/1/05 46.2K
[ZpemosMenu 6/1/07 B.82K

/BpeviceConfig 1/1/05 B83.0K
[ZDeviceConfig 1/1/05 234K
[ZE2ConfigMenu 6/1/07 14.2K
i 1/1/05 99.0K
[Z1mageDemo 6/1/07 2.95K
6/19/06 6.26K
a 149K

A

For upgrades, EZConfig Client is located in the IPSM image installed on the workstation. This EXE must
be copied and pasted into the \IPsM folder on the terminal. For more information, see Installing an
Upgrade on the Terminal on page 1-8.

Using EZConfig Client
1. On the Dolphin terminal, tap Start > Power Tools. The Power Tools Main Window (see page 1-2)
opens.

You can scan the first bar code from the Power Tools main window by pressing the SCAN key; see
page 2-36 for details.

EZConfig Client can also be launched with a HotKey from any window; see page 2-37 for details.

ExM

EZConfig EZConfig

2. Tap EZConfig Utilities s > EZConfig Editor & . The EZConfig Client window opens.

Status: Read 0 barcodes of O

Accept Unsecure [

3. Point the terminal at the first EZConfig Editor bar code, then press the SCAN key.
4. EZConfig Client decodes the bar code.




If there is only one bar code in the package, EZConfig Client deploys the package.

If there is more than one bar code in the package, EZConfig Client decodes the bar code, records
that one bar code has been read, and waits for the next scan.

e | E2Config Cl

Package ID: 1
Status: Read 1 barcode of 2

Accept Unsecure [

5. Scan all the bar codes in the package. Bar codes can be scanned in any order.

Note: If the EXM file is programmed to launch an application such as ScanWedge, a window pops up informing you
of initialization.

Cancel

EXM File Processing

After decoding, EZConfig Client saves EXM files to the location in the terminal selected in the Remote
Path (page 2-23) field on the Bar Codes Tab (page 2-22). (If the Temporary, page 2-25, option is selected
in the bar code, EZConfig Client does not save the EXM file.)

There are two types of EXM files: configuration documents and registry documents. EZConfig Client
processes each type of file differently.

Configuration Documents

If the EXM file was associated with an application, EZConfig Client launches and deploys the
data to that application for processing.




Note: DeviceConfig.exm must be associated with DeviceConfig.exe to be processed on the terminal
appropriately. After decoding the bar code, EZConfig Client deploys the data to
DeviceConfig.exe, which applies the settings to the terminal.

Registry Documents

Registry documents are always associated with EZConfig Client. The Execute option
(Execute, page 2-16) determines whether the registry is updated or not. If Execute is selected,
EZConfig Client updates the registry immediately after decoding the bar code.

Multiple Bar Codes

Some EXM files generate more than one bar code. If multiple bar codes were generated, EZConfig Client
recognizes that there is more than one bar code in the package and tracks each bar code scanned and
decoded. Bar codes can be scanned in any order, but EZConfig Client does not deploy the data until all
the bar codes in the package have been scanned.

EZConfig Client Window

Package ID: 1
Status: Read 1 barcode of 2

Accept Unsecure [

Field Description
Package ID This is the ID of the entire package.
EZConfig Editor assigns an ID to bar code packages when creating the bar code.
Status This field displays the decode status of the bar codes scanned so far.
If there is more than one bar code in the package, this field acts as a decode
counter.

The Status field displays:
* How many bar codes have been scanned and

e How many bar codes are in the package

Read # box This box displays the list of bar codes scanned and decoded.

Accept Unsecure This option allows EZConfig Client to scan bar codes that are not encrypted.
Note: By default, all bar codes created in EZConfig Editor are encrypted.

Scanning Bar Codes Directly from the Power Tools Main Window

When the Power Tools or Demos main windows are open, press the SCAN key and:

e Ifthere is only one bar code in the package, EZConfig Client decodes and deploys the bar code without
opening the EZConfig Client window.

* If there are multiple bar codes in the package, EZConfig Client decodes the first bar code and opens
the EZConfig Client window showing that one bar code in the package has been scanned.
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Launching EZConfig Client with a HotKey

Pressing ALT + SCAN launches EZConfig Client from any application window after you activate the

HotKeys Power Tool; see HotKeys on page 6-5.

ScanWedge

Bar code decoding in EZConfig Client is compatible with ScanWedge. You can set ScanWedge to pass

bar code information to EZConfig Client for further processing.
For details, see Accept EZConfig on page 5-4.

Command Line Arguments

/%filename Executes the EXM file; this is the default entry.
/a Quiet mode

/s Full screen

/o No menu

/e Exit if first scan fails to deliver a valid bar code
/u Accept (decode) unsecure bar codes







DeviceConfig

Overview

DeviceConfig consists of the DeviceConfig.exe and the DeviceConfig.exm file located in the \IPSM
folder. DeviceConfig.exe looks for and applies the settings in the DeviceConfig.exm file.

DeviceConfig.exm File

The DeviceConfig.exm file contains terminal configuration settings. Because this file is stored in the
\IPsM folder, its configuration settings persist through cold boots and should be considered system
defaults.

Enabling DeviceConfig Functionality

By default, all sections except the About Section (see page 3-9) are disabled, which means that the key
values are not applied to the terminal. To use the DeviceConfig.exm file to configure the terminal, enable
the sections and keys required by your configuration in EZConfig Editor (page 2-2) on the workstation or
EZConfig Editor on the Terminal (page 2-30).

Autorun

Autorun (see page 4-1) launches DeviceConfig.exe, which applies the DeviceConfig.exm settings, then
launches a cold boot followed by a warm boot.

Bar Code Delivery

When the DeviceConfig.exm file is delivered to the terminal via bar code, EZConfig Client launches
DeviceConfig.exe automatically after decoding. DeviceConfig.exe then applies the settings in
theDeviceConfig.exm file in the terminal. For more information, see Creating Bar Codes (page 2-21) and
EZConfig Client (page 2-34).

The DeviceConfig.exm file must be associated with DeviceConfig.exe for EZConfig Client to launch
DeviceConfig.exe after decoding the bar code. In EZConfig Editor, the associated application path must
be

\IPSM\deviceconfig.exe
For more information, see Associating Applications, page 2-16.

Settings in the WLAN Supplicant

Many settings in the DeviceConfig.exm file match the settings in the WLAN Supplicant on the terminal
that allow the user to enter and save the same values. If a user changes a setting in the WLAN Supplicant,
that setting is applied but stored in RAM memory and erased during the next cold boot. During the next
cold boot, Autorun launches DeviceConfig, which then re-applies the settings in the DeviceConfig.exm
file.




DeviceConfig.exm Sections and Keys

The sections and keys in the DeviceConfig.exm file are locked, which means that you can change values
but not names or descriptions.

Section Name | Description See Page

Connections Configures communication parameters. There are child sections 3-2
that configure the IrDA port, the on-board radios, and the
ActiveSync connection.

System Configures basic system settings. 3-9

Applications Configures software applications. 3-10

Connections Section
The Connections section contains child sections that set communication parameters on the terminal.

Beam Section

The Beam section enables and disables the IrDA port.

Radio Manager Section

In the Radio Manager, typically, you would enable the radio in the WiFi section, enable DHCP in the
TCPIP section, then configure the radio settings in the Security\Supplicant\ProfileX or
Security\NonSupplicant section.

WiFi Section
The keys in the WiFi section control the settings of the WLAN radio.

Key Description Default | Available Values
Value
Enable Enables and disables the WLAN radio. 1 O=Disabled

1=Enabled; if enabled, the GSM radio
section is disabled automatically

PowerMode Specifies the power save mode. 1 1=Disable; radio is powered
constantly (power save mode is
not used)

2=Always Enable; power save mode
is used

3=Auto Enable; EPSParm key
defines radio vs. battery

performance
EPSParm When PowerMode is set to 3 (Auto N/A X=A value between 1 and 10, where:
Enable), this parameter specifies radio 1=Best Radio Performance
vs. battery performance. (Minimum)

10=Best Battery Life (Maximum)




WiFi Section

The keys in the WiFi section control the settings of the WLAN radio.

Key Description Default | Available Values
Value
DriverName Specifies the name of the radio driver. N/A X=A value in the drop-down list; radio
This string must match the name of the driver names are terminal-specific.
driver for the current device. Different Dolphins have different
radio drivers.
TCPIP Section

The keys in the TCPIP section determine how the radio handles IP addresses.

Key

Description

Default
Value

Available Values

DHCP

Enables and disables DHCP (Dynamic
Host Configuration Protocol).

1

0=Disabled; the static IP address in
the IPAddress key is used for the
radio interface.

1=Enabled; the IP address for the
radio interface is requested from a
DHCP server.

The remaining keys need to be set when DHCP is disabled. When DHC
dynamically requested from a DHCP server.

P is enabled, these numbers are

IPAddress Static IP address for the radio N/A Static IP address
interface.
SubnetMask SubNet mask for the static IP address. | N/A Subnet mask address
DefaultGateway | Default gateway for the static IP N/A Gateway address
address.
DNS Domain name server for the static IP N/A Domain name server address
address.
Domain Domain name for the terminal N/A Terminal’s domain name
WINS Windows name server. N/A Windows name server address




Security Section

The Security section has no keys and one child section named “Supplicant,” which contains several
profile subsections.

Supplicant Section

The Supplicant section consists of a number of child sections. The default child section is named Profile1
and contains all the keys necessary to create a configuration profile for the WLAN radio.

To create multiple radio configurations, copy the Profile1 section and paste it at the root level of the
Supplicant section. Then, rename that profile and configure the keys according the desired network
configuration. Each child section name is arbitrary, but each name must be different.

The Supplicant section contains one key named ActiveProfile. Type in the Value equal to name of one
of the desired profile child sections.

g

|| Key Walue
Active Profile Prafilel

q Profilel

When DeviceConfig is activated on the terminal, the terminal will apply the settings in the profile specified
in the ActiveProfile key. If the ActiveProfile key does not have a matching profile, the radio will be enabled
by DeviceConfig but no specific radio configuration will be activated, which means that the radio will not
connect to your network.

Profile Subsections

Each Profile subsection contains the keys that configure the radio connection from the terminal to the
network.

Key Description Default | Available Values
Value
SSID The service set identifier used to connect to N/A X=Your network’s SSID
network; usually the network name of the Any=Connect to any network
access point or peer station.
Assoc. Mode | The general association mode (sometimes N/A * None (no authentication or
called “authentication”) of the radio. encryption)
e WEP
e |EEE 802.1X
* WPA-Personal (PSK)
¢ WPA-Enterprise (EAP)
¢ WPA(2)-Personal (PSK)

WPA(2)-Enterprise (EAP)

Encryption The encryption mode available for the N/A Open & Shared (WEP)
association mode. TKIP, AES-CCMP, TKIP &
CCMP (WPA)




Profile Subsections
Each Profile subsection contains the keys that configure the radio connection from the terminal to the

network.
Key Description Default | Available Values
Value
EAP Method | Available EAP methods for IEEE 802.1X and | N/A * LEAP
WPA(2)-Enterprise (EAP) association modes. * PEAPvVO-MSCHAPV2
* PEAPv1-MSCHAPV2
e PEAPv1-GTC
e PEAPvV1-TLS
¢ FAST-MSCHAPV2
e FAST-GTC
e FAST-TLS
e TLS
e TTLS-MD5
e TTLS-MSCHAPV2
e TTLS-GTC
PSK Enter the private share key for the WEP N/A User-defined
association mode.
Identity This is the 802.1X identity supplied to the N/A User-defined
authenticator. The identity value can be up to
63 ASCII characters and is case-sensitive.
Password This is the password used for MD5-Challenge | N/A User-defined
or EAP authentication. It may contain up to 63
ASCII characters and is case-sensitive.
Asterisks appear instead of characters for
enhanced security.
Anonymous ID | Enter the anonymous ID. This ID creates a N/A User-defined
tunnel through which the real ID (as entered in
the ldentity field) can pass.
For additional security, make this ID different
than the one entered in the Identity field.
Tunnel PAC For EAP-FAST, a one-time provisioning N/A Enter the address on the
Machine PAC exchange establishes a shared secret, called Dolphin terminal of either PAC
a Protected Access Credential (PAC) Key. (tunnel or machine).
That PAC Key is used for all subsequent Note: The PACs must be
authentications. located on the Dolphin
terminal!
Provisioning Provisioning refers to service activation and N/A * No Provisioning
involves programming various network * Anonymous
databases with the customer's information. ¢ Authenticated
* Anonymous + Authenticated
CA and/or CA certificates are any certificates created by | N/A Enter the address on the
Client a certified authority (CA). Dolphin terminal of either
Certificate Client certificates contain information that certificate (CA or Client).

identifies the user, as well as information
about the organization that issued the
certificate. This ensures that you can encrypt
data end-to-end.

The certificates must be
located on the Dolphin
terminal!




Profile Subsections

Each Profile subsection contains the keys that configure the radio connection from the terminal to the
network.

Key Description Default | Available Values
Value
Private Key Private keys are used with certain types of N/A Enter the address on the
EAP authentication. Dolphin terminal of the private
key.

The private key must be
located on the Dolphin

terminal!
Priv Key Private keys can be locked by passwords. N/A Enter the password that
Password unlocks t